Chapter 2: Parametric Analysis in ANSYS Workbench Using ANSYS Fluent

This tutorial is divided into the following sections:

2.1. Introduction
2.2. Prerequisites
2.3. Problem Description
2.4. Setup and Solution

2.1. Introduction

This tutorial illustrates using an ANSYS Fluent fluid flow system in ANSYS Workbench to set up and solve a three-dimensional turbulent fluid flow and heat transfer problem in an automotive heating, ventilation, and air conditioning (HVAC) duct system. ANSYS Workbench uses parameters and design points to allow you to run optimization and what-if scenarios. You can define both input and output parameters in ANSYS Fluent that can be used in your ANSYS Workbench project. You can also define parameters in other applications including ANSYS DesignModeler and ANSYS CFD-Post. Once you have defined parameters for your system, a Parameters cell is added to the system and the Parameter Set bus bar is added to your project. This tutorial is designed to introduce you to the parametric analysis utility available in ANSYS Workbench.

The tutorial starts with a Fluid Flow (Fluent) analysis system with pre-defined geometry and mesh components. Within this tutorial, you will redefine the geometry parameters created in ANSYS DesignModeler by adding constraints to the input parameters. You will use ANSYS Fluent to set up and solve the CFD problem. While defining the problem set-up, you will also learn to define input parameters in ANSYS Fluent. The tutorial will also provide information on how to create output parameters in ANSYS CFD-Post.

This tutorial demonstrates how to do the following:

• Add constraints to the ANSYS DesignModeler input parameters.

• Create an ANSYS Fluent fluid flow analysis system in ANSYS Workbench.

• Set up the CFD simulation in ANSYS Fluent, which includes:
  – Setting material properties and boundary conditions for a turbulent forced convection problem.
  – Defining input parameters in Fluent

• Define output parameters in CFD-Post

• Create additional design points in ANSYS Workbench.

• Run multiple CFD simulations by updating the design points.
• Analyze the results of each design point project in ANSYS CFD-Post and ANSYS Workbench.

**Important**

The mesh and solution settings for this tutorial are designed to demonstrate a basic parameterization simulation within a reasonable solution time-frame. Ordinarily, you would use additional mesh and solution settings to obtain a more accurate solution.

### 2.2. Prerequisites

This tutorial assumes that you are already familiar with the ANSYS Workbench interface and its project workflow (for example, ANSYS DesignModeler, ANSYS Meshing, ANSYS Fluent, and ANSYS CFD-Post). This tutorial also assumes that you have completed *Introduction to Using ANSYS Fluent in ANSYS Workbench: Fluid Flow and Heat Transfer in a Mixing Elbow* (p. 1), and that you are familiar with the ANSYS Fluent graphical user interface. Some steps in the setup and solution procedure will not be shown explicitly.

### 2.3. Problem Description

In the past, evaluation of vehicle air conditioning systems was performed using prototypes and testing their performance in test labs. However, the design process of modern vehicle air conditioning (AC) systems improved with the introduction of Computer Aided Design (CAD), Computer Aided Engineering (CAE) and Computer Aided Manufacturing (CAM). The AC system specification will include minimum performance requirements, temperatures, control zones, flow rates, and so on. Performance testing using CFD may include fluid velocity (air flow), pressure values, and temperature distribution. Using CFD enables the analysis of fluid through very complex geometry and boundary conditions.

As part of the analysis, a designer can change the geometry of the system or the boundary conditions such as the inlet velocity, flow rate, and so on, and view the effect on fluid flow patterns. This tutorial illustrates the AC design process on a representative automotive HVAC system consisting of both an evaporator for cooling and a heat exchanger for heating requirements. This HVAC system is symmetric, so the geometry has been simplified using a plane of symmetry to reduce computation time.
Figure 2.1: Automotive HVAC System
Figure 2.2: HVAC System Valve Location Details

Figure 2.1: Automotive HVAC System (p. 75) shows a representative automotive HVAC system. The system has three valves (as shown in Figure 2.2: HVAC System Valve Location Details (p. 76)), which control the flow in the HVAC system. The three valves control:

- Flow over the heat exchanger coils
- Flow towards the duct controlling the flow through the floor vents
- Flow towards the front vents or towards the windshield

Air enters the HVAC system at 310 K with a velocity of 0.5 m/sec through the air inlet and passes to the evaporator and then, depending on the position of the valve controlling flow to the heat exchanger, flows over or bypasses the heat exchanger. Depending on the cooling and heating requirements, either the evaporator or the heat exchanger would be operational, but not both at the same time. The position of the other two valves controls the flow towards the front panel, the windshield, or towards the floor ducts.

The motion of the valves is constrained. The valve controlling flow over the heat exchanger varies between 25° and 90°. The valve controlling the floor flow varies between 20° and 60°. The valve controlling flow towards front panel or windshield varies between 15° and 175°.

The evaporator load is about 200 W in the cooling cycle. The heat exchanger load is about 150 W.

This tutorial illustrates the easiest way to analyze the effects of the above parameters on the flow pattern/distribution and the outlet temperature of air (entering the passenger cabin). Using the parametric
analysis capability in ANSYS Workbench, a designer can check the performance of the system at various
design points.

Figure 2.3: Flow Pattern for the Cooling Cycle

2.4. Setup and Solution

To help you quickly identify graphical user interface items at a glance and guide you through the steps
of setting up and running your simulation, the ANSYS Fluent Tutorial Guide uses several type styles and
mini flow charts. See Typographical Conventions Used In This Manual (p. xvi) for detailed information.

The following sections describe the setup and solution steps for this tutorial:
  2.4.1. Preparation
  2.4.2. Adding Constraints to ANSYS DesignModeler Parameters in ANSYS Workbench
  2.4.3. Setting Up the CFD Simulation in ANSYS Fluent
  2.4.4. Defining Input Parameters in ANSYS Fluent
  2.4.5. Solving
  2.4.6. Postprocessing and Setting the Output Parameters in ANSYS CFD-Post
2.4.7. Creating Additional Design Points in ANSYS Workbench
2.4.8. Postprocessing the New Design Points in CFD-Post
2.4.9. Summary

2.4.1. Preparation

To prepare for running this tutorial:

1. Set up a working folder on the computer you will be using.

Note

If you do not have a login, you can request one by clicking Customer Registration on the log in page.

3. Enter the name of this tutorial into the search bar.
4. Narrow the results by using the filter on the left side of the page.
   a. Click ANSYS Fluent under Product.
   b. Click 18.0 under Version.
5. Select this tutorial from the list.
6. Click the workbench-parameter-tutorial_R180.zip link to download the input files.
7. Unzip the workbench-parameter-tutorial_R180.zip file to your working folder.

The extracted workbench-parameter-tutorial folder contains a single archive file fluent-workbench-param.wbpz that includes all supporting input files of the starting ANSYS Workbench project and a folder called final_project_files that includes the archived final version of the project. The final result files incorporate ANSYS Fluent and ANSYS CFD-Post settings and all already defined design points (all that is required is to update the design points in the project to generate corresponding solutions).

Note

ANSYS Fluent tutorials are prepared using ANSYS Fluent on a Windows system. The screen shots and graphic images in the tutorials may be slightly different than the appearance on your system, depending on the operating system or graphics card.

2.4.2. Adding Constraints to ANSYS DesignModeler Parameters in ANSYS Workbench

In this step, you will start ANSYS Workbench, open the project file, review existing parameters, create new parameters, and add constraints to existing ANSYS DesignModeler parameters.
1. From the Windows **Start** menu, select **Start > All Programs > ANSYS 18.0 > Workbench 18.0** to start ANSYS Workbench.

This displays the ANSYS Workbench application window, which has the **Toolbox** on the left and the **Project Schematic** to its right. Various supported applications are listed in the **Toolbox**, and the components of the analysis system are displayed in the **Project Schematic**.

---

**Note**

When you first start ANSYS Workbench, the **Getting Started** message window is displayed, offering assistance through the online help for using the application. You can keep the window open, or close it by clicking **OK**. If you need to access the online help at any time, use the **Help** menu, or press the **F1** key.

---

2. Restore the archive of the starting ANSYS Workbench project to your working directory.

   **File → Restore Archive...**

   The **Select Archive to Restore** dialog box appears.

   a. Browse to your working directory, select the project archive file `fluent-workbench-param.wbpz`, and click **Open**.

      The **Save As** dialog box appears.

   b. Browse, if necessary, to your working folder and click **Save** to restore the project file, `fluent-workbench-param.wbpj`, and a corresponding project folder, `fluent-workbench-param_files`, for this tutorial.

Now that the project archive has been restored, the project will automatically open in ANSYS Workbench.
The project (fluent-workbench-param.wbpj) already has a Fluent-based fluid flow analysis system that includes the geometry and mesh, as well as some predefined parameters. You will first examine and edit parameters within Workbench, then later proceed to define the fluid flow model in ANSYS Fluent.

3. Open the Files view in ANSYS Workbench so you can view the files associated with the current project and are written during the session.

View → Files
Figure 2.5: The Project Loaded into ANSYS Workbench Displaying Properties and Files View

Note the types of files that have been created for this project. Also note the states of the cells for the Fluid Flow (Fluent) analysis system. Since the geometry has already been defined, the status of the Geometry cell is Up-to-Date (✓). Since the mesh is not complete, the Mesh cell’s state is Refresh Required (⟳), and since the ANSYS Fluent setup is incomplete and the simulation has yet to be performed, with no corresponding results, the state for the Setup, Solution, and Results cells is Unfulfilled (⟲). For more information about cell states, see the Workbench User’s Guide.

4. Review the input parameters that have already been defined in ANSYS DesignModeler.

   a. Double-click the Parameter Set bus bar in the ANSYS Workbench Project Schematic to open the Parameters Set tab.

   Note

   To return to viewing the Project Schematic, click the Project tab.
b. In the **Outline of All Parameters** view (Figure 2.6: Parameters Defined in ANSYS DesignModeler (p. 82)), review the following existing parameters:

- The parameter `hcpos` represents the valve position that controls the flow over the heat exchanger. When the valve is at an angle of 25°, it allows the flow to pass over the heat exchanger. When the angle is 90°, it completely blocks the flow towards the heat exchanger. Any value in between allows some flow to pass over the heat exchanger giving a mixed flow condition.

- The parameter `ftpos` represents the valve position that controls flow towards the floor duct. When the valve is at an angle of 20°, it blocks the flow towards the floor duct and when the valve angle is 60°, it unblocks the flow.

- The parameter `wsfpos` represents the valve position that controls flow towards the windshield and the front panel. When the valve is at an angle of 15°, it allows the entire flow to go towards the windshield. When the angle is 90°, it completely blocks the flow towards windshield as well as the front panel. When the angle is 175°, it allows the flow to go towards the windshield and the front panel.

**Figure 2.6: Parameters Defined in ANSYS DesignModeler**

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ID</td>
<td>Parameter Name</td>
<td>Value</td>
<td>Unit</td>
</tr>
<tr>
<td>2</td>
<td>Input Parameters</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Fluid Flow (FLUENT) (A1)</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>P1</td>
<td>hcpos</td>
<td>90</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>P2</td>
<td>ftpos</td>
<td>25</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>P3</td>
<td>wsfpos</td>
<td>175</td>
<td></td>
</tr>
<tr>
<td>*</td>
<td>New input parameter</td>
<td>New name</td>
<td>New expression</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Output Parameters</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>*</td>
<td>New output parameter</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Charts</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5. In the **Outline of All Parameters** view, create three new named input parameters.

a. In the row that contains **New input parameter**, click the parameter table cell with **New name** (under the **Parameter Name** column) and enter `input_hcpos`. Note the ID of the parameter that appears in column A of the table. For the new input parameter, the parameter **ID** is **P4**. In the **Value** column, enter **15**.

b. In a similar manner, create two more parameters named `input_ftpos` and `input_wsfpos`. In the **Value** column, enter **25**, and **90** for each new parameter (**P5** and **P6**), respectively.
6. Select the row (or any cell in the row) that corresponds to the \(hcpos\) parameter. In the **Properties of Outline** view, change the value of the \(hcpos\) parameter in the **Expression** field from 90 to the expression \(\min(\max(25, P4), 90)\). This puts a constraint on the value of \(hcpos\), so that the value always remains between 25° and 90°. The redefined parameter \(hcpos\) is automatically passed to ANSYS DesignModeler. Alternatively, the same constraint can also be set using the expression \(\max(25, \min(P4, 90))\).

After defining this expression, the parameter becomes a derived parameter that is dependent on the value of the parameter \(input_{hcpos}\) with ID \(P4\). The derived parameters are unavailable for editing in the **Outline of All Parameters** view and could be redefined only in the **Properties of Outline** view.

---

**Important**

When entering expressions, you must use the list and decimal delimiters associated with your selected language in the Workbench regional and language settings, which correspond to the regional settings on your machine. The instructions in this tutorial assume that your systems uses “,” as a decimal separator and “,” as a list separator.
7. Select the row or any cell in the row that corresponds to the \textit{ftpos} parameter and create a similar expression for \textit{ftpos} \texttt{min(max(20,P5),60)}. 

\textbf{Figure 2.8: Constrained Parameter h\textit{cpos}}
8. Create a similar expression for $\text{wsfpos} : \min(15, P6, 175)$. 

![Figure 2.9: Constrained Parameter $f_{tpos}$](image-url)
9. Click the X on the right side of the **Parameters Set** tab to close it and return to the **Project Schematic**.

   Note the new status of the cells in the Fluid Flow (Fluent) analysis system. Since we have changed the values of \( h_{cpos} \), \( f_{tpos} \), and \( w_{sfpos} \) to their new expressions, the **Geometry** and **Mesh** cells now indicates Refresh Required (\( \mathbb{R} \)).

10. Update the **Geometry** and **Mesh** cells.
   
   a. Right-click the **Geometry** cell and select the **Update** option from the context menu.

   b. Likewise, right-click the **Mesh** cell and select the **Refresh** option from the context menu. Once the cell is refreshed, then right-click the **Mesh** cell again and select the **Update** option from the context menu.

11. Save the project in ANSYS Workbench.

   In the main menu, select **File \( \rightarrow \) Save**
2.4.3. Setting Up the CFD Simulation in ANSYS Fluent

Now that you have edited the parameters for the project, you will set up a CFD analysis using ANSYS Fluent. In this step, you will start ANSYS Fluent, and begin setting up the CFD simulation.

2.4.3.1. Starting ANSYS Fluent

In the ANSYS Workbench Project Schematic, double-click the Setup cell in the ANSYS Fluent fluid flow analysis system. You can also right-click the Setup cell to display the context menu where you can select the Edit... option.

When ANSYS Fluent is first started, Fluent Launcher is displayed, allowing you to view and/or set certain ANSYS Fluent start-up options.

*Fluent Launcher allows you to decide which version of ANSYS Fluent you will use, based on your geometry and on your processing capabilities.*

**Figure 2.11: ANSYS Fluent Launcher**

![Fluent Launcher](image)

1. Ensure that the proper options are enabled.

**Important**

Note that the Dimension setting is already filled in and cannot be changed, since ANSYS Fluent automatically sets it based on the mesh or geometry for the current system.
a. Ensure that the **Display Mesh After Reading** and **Workbench Color Scheme** options are enabled.

**Note**

An option is enabled when there is a check mark in the check box, and disabled when the check box is empty. To change an option from disabled to enabled (or vice versa), click the check box or the text.

b. Ensure that **Serial** is selected from the **Processing Options** list.

**Note**


c. Ensure that the **Double Precision** option is disabled.

**Note**

Fluent will retain your preferences for future sessions.

2. Click **OK** to launch ANSYS Fluent.
2.4.3.2. Setting Up Physics

1. In the **Solver** group of the **Setting Up Physics** ribbon tab, retain the default selection of the steady pressure-based solver.

   ![Setting Up Physics → Solver](image)

2. Set up your models for the CFD simulation using the **Models** group of the **Setting Up Physics** ribbon tab.

   ![Models](image)

   a. Enable heat transfer by activating the energy equation.
In the **Setting Up Physics** ribbon tab, select **Energy** (Models group).

**Setting Up Physics → Models → Energy**

b. Enable the $k-\varepsilon$ turbulence model.

**Setting Up Physics → Models → Viscous...**

i. Select **k-epsilon (2 eqn)** from the **Model** group box.

ii. Select **Enhanced Wall Treatment** from the **Near-Wall Treatment** group box.
The default Standard Wall Functions are generally applicable when the cell layer adjacent to the wall has a y+ larger than 30. In contrast, the Enhanced Wall Treatment option provides consistent solutions for all y+ values. Enhanced Wall Treatment is recommended when using the k-epsilon model for general single-phase fluid flow problems. For more information about Near Wall Treatments in the k-epsilon model refer to the Fluent User's Guide.

iii. Click OK to retain the other default settings, enable the model, and close the Viscous Model dialog box.

Note that the Viscous... label in the ribbon is displayed in blue to indicate that the Viscous model is enabled.

3. Define a heat source cell zone condition for the evaporator volume.

[Setting Up Physics → Zones → Cell Zones]

Note

All cell zones defined in your simulation are listed in the Cell Zone Conditions task page and under the Setup/Cell Zone Conditions tree branch.

a. In the Cell Zone Conditions task page, under the Zone list, select fluid-evaporator and click Edit... to open the Fluid dialog box.

b. In the Fluid dialog box, enable Source Terms.

c. In the Source Terms tab, click the Edit... button next to Energy.
d. In the **Energy sources** dialog box, change the **Number of Energy sources** to 1.

e. For the new energy source, select **constant** from the drop-down list, and enter $-787401.6 \text{ W/m}^3$ — based on the evaporator load (200 W) divided by the evaporator volume ($0.000254 \text{ m}^3$) that was computed earlier.

f. Click **OK** to close the **Energy Source** dialog box.

g. Click **OK** to close the **Fluid** dialog box.

### 2.4.4. Defining Input Parameters in ANSYS Fluent

You have now started setting up the CFD analysis using ANSYS Fluent. In this step, you will define boundary conditions and input parameters for the velocity inlet.

1. Define an input parameter called **in_velocity** for the velocity at the inlet boundary.

   a. In the **Setting Up Physics** tab, click **Boundaries** (**Zones** group).

      ![Setting Up Physics → Zones → Boundaries](image)

      This opens the **Boundary Conditions** task page.

      **Note**

      All boundaries defined in the case are also displayed under the **Setup/Boundary Conditions** tree branch.

   b. In the **Boundary Conditions** task page, click the **Toggle Tree View** button (in the upper right corner), and under the **Group By** category, select **Zone Type**. This displays boundary zones grouped by zone type.

   c. Under the **Inlet** zone type, double-click **inlet-air**.
d. In the **Velocity Inlet** dialog box, from the **Velocity Magnitude** drop-down list, select **New Input Parameter**....

*This displays the Input Parameter Properties dialog box.*

e. Enter `in_velocity` for the **Name**, and enter 0.5 m/s for the **Current Value**.

f. Click **OK** to close the Input Parameter Properties dialog box.

g. Under the **Turbulence** group box, from the Specification Method drop-down list, select **Intensity** and **Hydraulic Diameter**.

h. Retain the value of 5 % for **Turbulent Intensity**.
i. Enter 0.061 for Hydraulic Diameter (m).

2. Define an input parameter called in_temp for the temperature at the inlet boundary.

   a. In the Thermal tab of the Velocity Inlet dialog box, select New Input Parameter... from the Temperature drop-down list.

   b. Enter in_temp for the Name and enter 310 K for the Current Value in the Input Parameter Properties dialog box.

   c. Click OK to close the Input Parameter Properties dialog box.

   d. Click OK to close the Velocity Inlet dialog box.

3. Review all of the input parameters that you have defined in ANSYS Fluent under the Parameters & Customization/Parameters tree branch.

   Parameters & Customization → Parameters → Input Parameters

Figure 2.13: The Input Parameters Sub-Branch in ANSYS Fluent
These parameters are passed to ANSYS Fluent component system in ANSYS Workbench and are available for editing in ANSYS Workbench (see Figure 2.14: The Parameters View in ANSYS Workbench (p. 95)).

**Figure 2.14: The Parameters View in ANSYS Workbench**

<table>
<thead>
<tr>
<th>ID</th>
<th>Parameter Name</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Input Parameters</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Fluid Flow (FLUENT) (A1)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>P1</td>
<td>hcos</td>
<td>25</td>
</tr>
<tr>
<td>4</td>
<td>P2</td>
<td>fcos</td>
<td>25</td>
</tr>
<tr>
<td>5</td>
<td>P3</td>
<td>wsfcos</td>
<td>90</td>
</tr>
<tr>
<td>6</td>
<td>P7</td>
<td>in_velocity</td>
<td>0.5</td>
</tr>
<tr>
<td>7</td>
<td>P9</td>
<td>in_temp</td>
<td>310</td>
</tr>
<tr>
<td>8</td>
<td>P4</td>
<td>input_hcos</td>
<td>15</td>
</tr>
<tr>
<td>9</td>
<td>P5</td>
<td>input_fcos</td>
<td>25</td>
</tr>
<tr>
<td>10</td>
<td>P6</td>
<td>input_wsfcos</td>
<td>90</td>
</tr>
<tr>
<td>11</td>
<td>New input parameter</td>
<td>New name</td>
<td>New expression</td>
</tr>
<tr>
<td>12</td>
<td>Output Parameters</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>New output parameter</td>
<td>New expression</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Charts</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

4. Set the turbulence parameters for backflow at the front outlets and foot outlets.

a. In the **Boundary Conditions** task page, type **outlet** in the **Zone** filter text entry field. Note that as you type, the names of the boundary zones beginning with the characters you entered appear in the boundary condition zone list.

**Note**

- The search string can include wildcards. For example, entering *let* will display all zone names containing let, such as inlet and outlet.
- To display all zones again, click the red X icon in the **Zone** filter.

b. Double-click **outlet-front-mid**.
c. In the Pressure Outlet dialog box, under the Turbulence group box, select Intensity and Hydraulic Diameter from the Specification Method drop-down list.

d. Retain the value of 5 for Backflow Turbulent Intensity (%).

e. Enter 0.044 for Backflow Hydraulic Diameter (m).

   These values will only be used if reversed flow occurs at the outlets. It is a good idea to set reasonable values to prevent adverse convergence behavior if backflow occurs during the calculation.

f. Click OK to close the Pressure Outlet dialog box.

g. Copy the boundary conditions from outlet-front-mid to the other front outlet.

   Setup → Boundary Conditions → outlet-front-mid → Copy...
i. Confirm that outlet-front-mid is selected in the From Boundary Zone selection list.

ii. Select outlet-front-side-left in the To Boundary Zones selection list.

iii. Click Copy to copy the boundary conditions.

   Fluent will display a dialog box asking you to confirm that you want to copy the boundary conditions.

iv. Click OK to confirm.

v. Close the Copy Conditions dialog box.

h. In a similar manner, set the backflow turbulence conditions for outlet-foot-left using the values in the following table:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specification Method</td>
<td>Intensity and Hydraulic Diameter</td>
</tr>
<tr>
<td>Backflow Turbulent Intensity (%)</td>
<td>5</td>
</tr>
<tr>
<td>Backflow Hydraulic Diameter (m)</td>
<td>0.052</td>
</tr>
</tbody>
</table>

**2.4.5. Solving**

In the steps that follow, you will set up and run the calculation using the Solving ribbon tab.

**Note**

You can also use the task pages listed under the Solution branch in the tree to perform solution-related activities.

1. Set the Solution Methods.

   Solving → Solution → Methods...
This will open the **Solution Methods** task page.

a. From the **Scheme** drop-down list, select **Coupled**.

*The pressure-based coupled solver is the recommended choice for general fluid flow simulations.*

b. In the **Spatial Discretization** group box, configure the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pressure</td>
<td>PRESTO!</td>
</tr>
<tr>
<td>Momentum</td>
<td>First Order Upwind</td>
</tr>
<tr>
<td>Energy</td>
<td>First Order Upwind</td>
</tr>
</tbody>
</table>
This tutorial is primarily intended to demonstrate the use of parameterization and design points when running Fluent from Workbench. Therefore, you will run a simplified analysis using first order discretization, which will yield faster convergence. These settings were chosen to speed up solution time for this tutorial. Usually, for cases like this, we would recommend higher order discretization settings to be set for all flow equations to ensure improved results accuracy.

2. Initialize the flow field using the **Initialization** group of the **Solving** ribbon tab.

   ![Initialization Group](image1)

   a. Retain the default selection of **Hybrid Initialization**.
   
   b. Click the **Initialize** button.

3. Run the simulation in ANSYS Fluent from the **Run Calculation** group of the **Solving** tab.

   ![Run Calculation Group](image2)

   a. For **Number of Iterations**, enter **1000**.
   
   b. Click the **Calculate** button.

   *The solution converges within approximately 55 iterations.*

   Throughout the calculation, Fluent displays a warning in the console regarding reversed flow at the outlets. This behavior is expected in this case since air is redirected to the outlets, creating small regions of recirculation.

   **Note**

   The warning message can be switched off by setting the `solve/set/flow-warnings` text user interface (TUI) command to `no` in the console.


   ![File Group](image3)

   **File → Close Fluent**

5. Save the project in ANSYS Workbench.
2.4.6. Postprocessing and Setting the Output Parameters in ANSYS CFD-Post

In this step, you will visualize the results of your CFD simulation using ANSYS CFD-Post. You will plot vectors that are colored by pressure, velocity, and temperature, on a plane within the geometry. In addition, you will create output parameters within ANSYS CFD-Post for later use in ANSYS Workbench.

In the ANSYS Workbench **Project Schematic**, double-click the **Results** cell in the ANSYS Fluent fluid flow analysis system to start CFD-Post. You can also right-click the **Results** cell to display the context menu where you can select the **Edit...** option.

The CFD-Post application appears with the automotive HVAC geometry already loaded and displayed in outline mode. Note that ANSYS Fluent results (that is, the case and data files) are also automatically loaded into CFD-Post.

**Figure 2.15: The Automotive HVAC Geometry Loaded into CFD-Post**

1. Edit some basic settings in CFD-Post (for example, changing the background color to white).
   - **Edit → Options...**
     - In the **Options** dialog box, select **Viewer** under **CFD-Post** in the tree view.
b. Under the Background group, from the **Color Type** drop-down list, select **Solid**.

c. Click the **Color** sample bar to cycle through common color swatches until it displays white.

**Tip**

You can also click the ellipsis icon to bring up a color selector dialog box from which you can choose an arbitrary color.

d. Click **OK** to set the white background color for the display and close the **Options** dialog box.

2. Adjust the color-map legend to show the numbers in floating format.

   a. In the **Outline** tree view, double-click **Default Legend View 1** to display the **Details** view for the default legend to be used for your plots.

   b. In the **Definition** tab of the **Details** view, from the **Title Mode** drop-down list, select **Variable**.
Details of Default Legend View 1

<table>
<thead>
<tr>
<th>Definition</th>
<th>Appearance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title Mode</td>
<td>Variable</td>
</tr>
<tr>
<td>Show Legend Units</td>
<td>✓</td>
</tr>
<tr>
<td>Vertical</td>
<td>False</td>
</tr>
<tr>
<td>Location</td>
<td></td>
</tr>
<tr>
<td>X Justification</td>
<td>Left</td>
</tr>
<tr>
<td>Y Justification</td>
<td>Top</td>
</tr>
<tr>
<td>Position</td>
<td>0.02 0.15</td>
</tr>
</tbody>
</table>

3. Plot vectors colored by pressure.

   a. From the main menu, select **Insert → Vector** or click in the ANSYS CFD-Post toolbar.

      *This displays the Insert Vector dialog box.*

   b. Keep the default name of **Vector 1** by clicking **OK**.

   c. In the **Details** view for **Vector 1**, under the **Geometry** tab, configure the following settings.
i. Ensure **All Domains** is selected from the **Domains** drop-down list.

ii. From the **Locations** drop-down list, select **symmetry central unit**.

iii. From the **Sampling** drop-down list, select **Equally Spaced**.

iv. Set the **# of Points** to **10000**.

v. From the **Projection** drop-down list, select **Tangential**.

d. In the **Color** tab, configure the following settings.

<table>
<thead>
<tr>
<th>Details of Vector 1</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Geometry</strong></td>
</tr>
<tr>
<td>Domains</td>
</tr>
<tr>
<td>Definition</td>
</tr>
<tr>
<td>Locations</td>
</tr>
<tr>
<td>Sampling</td>
</tr>
<tr>
<td># of Points</td>
</tr>
<tr>
<td>Variable</td>
</tr>
<tr>
<td>Boundary Data</td>
</tr>
<tr>
<td>Projection</td>
</tr>
</tbody>
</table>

i. From the **Mode** drop-down list, select **Variable**.
ii. From the Variable drop-down list, select Pressure.

e. In the Symbol tab, configure the following settings.

```
<table>
<thead>
<tr>
<th>Geometry</th>
<th>Color</th>
<th>Symbol</th>
<th>Render</th>
<th>View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Symbol</td>
<td></td>
<td>Line Arrow</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Symbol Size</td>
<td>0.05</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Normalize Symbols</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

i. Set the Symbol Size to 0.05.

ii. Enable Normalize Symbols.

f. Click Apply.

Vector 1 appears under User Locations and Plots in the Outline tree view.

In the graphics display window, note that symmetry-central-unit shows the vectors colored by pressure. Use the controls in CFD-Post to rotate the geometry (for example, clicking the dark blue axis in the axis triad of the graphics window). Zoom into the view as shown in Figure 2.16: Vectors Colored by Pressure (p. 105).

---

**Note**

To better visualize the vector display, you can deselect the Wireframe view option under User Locations and Plots in the Outline tree view.
4. Plot vectors colored by velocity.
   a. In the Details view for Vector 1, under the Color tab, configure the following settings.
      i. Select Velocity from the Variable drop-down list.
      ii. Click Apply.
   The velocity vector plot appears on the symmetry-central-unit symmetry plane.
5. Plot vectors colored by temperature.

   a. In the Details view for Vector 1, under the Color tab, configure the following settings.

      i. Select Temperature from the Variable drop-down list.

      ii. Select User Specified from the Range drop-down list.

      iii. Enter 273 K for the Min temperature value.

      iv. Enter 310 K for the Max temperature value.

   v. Click Apply.

      The user-specified range is selected much narrower than the Global and Local ranges in order to better show the variation.
Figure 2.18: Vectors Colored by Temperature

Note the orientation of the various valves and how they impact the flow field. Later in this tutorial, you will change these valve angles to see how the flow field changes.

6. Create two surface groups.

Surface groups are collections of surface locations in CFD-Post. In this tutorial, two surface groups are created in CFD-Post that will represent all of the outlets and all of the front outlets. Once created, specific commands (or expressions) will be applied to these groups in order to calculate a particular numerical value at that surface.

a. Create a surface group consisting of all outlets.

i. With the **Outline** tree view open in the CFD-Post tree view, open the **Insert Surface Group** dialog box.

   **Insert → Location → Surface Group**
ii. Enter alloutlets for the Name of the surface group, and click OK to close the Insert Surface Group dialog box.

iii. In the Details view for the alloutlets surface group, in the Geometry tab, click the ellipsis icon next to Locations to display the Location Selector dialog box.

iv. Select all of the outlet surfaces (outlet foot left, outlet front mid, outlet front side left, and outlet windshield) in the Location Selector dialog box (hold Ctrl for multiple selection) and click OK.

v. Click Apply in the Details view for the new surface group. alloutlets appears under User Locations and Plots in the Outline tree view.

b. Create a surface group for the front outlets.
Perform the same steps as described above to create a surface group called `frontoutlets` with locations for the front outlets (outlet front mid and outlet front side left).

7. Create expressions in CFD-Post and mark them as ANSYS Workbench output parameters.

In this tutorial, programmatic commands or expressions are written to obtain numerical values for the mass flow rate from all outlets, as well as at the front outlets, windshield, and foot outlets. The surface groups you defined earlier are used to write the expressions.

a. Create an expression for the mass flow from all outlets.

i. With the **Expressions** tab open in the CFD-Post tree view, open the **Insert Expression** dialog box.

   - **Insert Expression**

ii. Enter `floutfront` for the **Name** of the expression and click OK to close the **Insert Expression** dialog box.

![Details of floutfront]

   - **Definition** tab: 

     \[-(\text{massFlow()}@\text{frontoutlets})^2\]

   - **Value**: 

     -0.000264112 [kg s^-1]

   - **Apply**

   - **Reset**

iii. In the **Details** view for the new expression, enter the following in the **Definition** tab.

   \[-(\text{massFlow()}@\text{frontoutlets})^2\]

   *The sign convention for `massFlow()` is such that a positive value represents flow into the domain and a negative value represents flow out of the domain. Since you are defining an expression for outflow from the ducts, you use the negative of the `massFlow()` result in the definition of the expression.*

iv. Click **Apply** to obtain a **Value** for the expression.

   *Note the new addition in the list of expressions in the **Expressions** tab in CFD-Post.*

   *In this case, there is a small net backflow into the front ducts.*
v. Right-click the new expression and select **Use as Workbench Output Parameter** from the context menu. A small "P" with a right-pointing arrow appears on the expression's icon.

b. Create an expression for the mass flow from the wind shield.
   i. Perform the same steps as described above to create an expression called `floutwindshield` with the following definition:

   ```plaintext
   -(massFlow()@outlet windshield)*2
   ```

   ii. Right-click the new expression and select **Use as Workbench Output Parameter** from the context menu.

c. Create an expression for the mass flow from the foot outlets.
   i. Perform the same steps as described above to create an expression called `floutfoot` with the following definition:

   ```plaintext
   -(massFlow()@outlet foot left)*2
   ```

   ii. Right-click the new expression and select **Use as Workbench Output Parameter** from the context menu.

d. Create an expression for the mass weighted average outlet temperature.
   i. Perform the same steps as described above to create an expression called `outlettemp` with the following definition:

   ```plaintext
   massFlowAveAbs(Temperature)@alloutlets
   ```

   ii. Right-click the new expression and select **Use as Workbench Output Parameter** from the context menu.

8. Close ANSYS CFD-Post.

   In the main menu, select **File → Close CFD-POST** to return to ANSYS Workbench.

9. In the **Outline of All Parameters** view of the **Parameter Set** tab (double-click **Parameter Set**), review the newly-added output parameters that you specified in ANSYS CFD-Post and when finished, click the **Project** tab to return to the **Project Schematic**.

10. If any of the cells in the analysis system require attention, update the project by clicking the **Update Project** button in the ANSYS Workbench toolbar.

11. Optionally, review the list of files generated by ANSYS Workbench. If the **Files** view is not open, select **View → Files** from the main menu.

   You will notice additional files associated with the latest solution as well as those generated by CFD-Post.
12. Save the project in ANSYS Workbench.

In the main menu, select **File → Save**

**Note**

You can also select the **Save Project** option from the CFD-Post **File** ribbon tab.

### 2.4.7. Creating Additional Design Points in ANSYS Workbench

Parameters and design points are tools that allow you to analyze and explore a project by giving you the ability to run optimization and what-if scenarios. Design points are based on sets of parameter values. When you define input and output parameters in your ANSYS Workbench project, you are essentially working with a design point. To perform optimization and what-if scenarios, you create multiple
design points based on your original project. In this step, you will create additional design points for
your project where you will be able to perform a comparison of your results by manipulating input
parameters (such as the angles of the various valves within the automotive HVAC geometry). ANSYS
Workbench provides a Table of Design Points to make creating and manipulating design points more
convenient.

1. Open the Table of Design Points.
   a. In the Project Schematic, double-click the Parameter Set bus bar to open the Table of Design
      Points view. If the table is not visible, select Table from the View menu in ANSYS Workbench.

      View → Table

      The table of design points initially contains the current project as a design point (DP0),
along with its corresponding input and output parameter values.

      Figure 2.20: Table of Design Points (with DP0)

      From this table, you can create new design points (or duplicate existing design points) and
      edit them (by varying one or more input parameters) to create separate analyses for future
      comparison of data.

2. Create a design point (DP1) by duplicating the current design point (DP0).
   a. Right-click the Current design point and select Duplicate Design Point from the context menu.

      The cells autofill with the values from the Current row.

   b. Scroll over to the far right to expose the Retain column in the table of design points, and ensure
      the check box in the row for the duplicated design point DP 1 (cell N4) is selected.

      This allows the data from this new design point to be saved before it is exported for future
      analysis.

3. Create another design point (DP2) by duplicating the DP1 design point.
   a. Right-click the DP1 design point and select Duplicate Design Point from the context menu.

      Since this is a duplicate of DP1, this design point will also have its data retained.

4. Edit values for the input parameters for DP1 and DP2.

   For DP1 and DP2, edit the values for your input parameters within the Table of Design Points
   as follows:

<table>
<thead>
<tr>
<th></th>
<th>input_hcpos</th>
<th>input_ftpos</th>
<th>input_wsfpos</th>
<th>in_velocity</th>
<th>in_temp</th>
</tr>
</thead>
<tbody>
<tr>
<td>DP1</td>
<td>45</td>
<td>45</td>
<td>45</td>
<td>0.6</td>
<td>300</td>
</tr>
<tr>
<td>DP2</td>
<td>90</td>
<td>60</td>
<td>15</td>
<td>0.7</td>
<td>290</td>
</tr>
</tbody>
</table>
Figure 2.21: Table of Design Points (with DP0, DP1, and DP2 Defined)

For demonstration purposes of this tutorial, in each design point, you are slightly changing the angles of each of the valves, and increasing the inlet velocity and the inlet temperature. Later, you will see how the results in each case vary.

5. Update all of your design points.

Click the **Update all Design Points** button in the ANSYS Workbench toolbar. Alternatively, you can also select one or more design points, right-click, and select **Update Selected Design Points** from the context menu. Click **OK** to acknowledge the information message notifying you that some open editors may close during the update process. By updating the design points, ANSYS Workbench takes the new values of the input parameters for each design point and updates the components of the associated system (for example, the geometry, mesh, settings, solution, and results), as well as any output parameters that have been defined.

---

**Note**

It may take significant time and/or computing resources to re-run the simulations for each design point.

---

6. Export the design points to separate projects.

This will allow you to work with calculated data for each design point.

a. Select the three design points, **DP0**, **DP1**, and **DP2** (hold **Shift** for multiple selection).

b. Right-click the selected design points and select **Export Selected Design Points**.

Note the addition of three more ANSYS Workbench project files (and their corresponding folders) in your current working directory (**fluent-workbench-param_dp0.wbpj**, **fluent-workbench-param_dp1.wbpj** and **fluent-workbench-param_dp2.wbpj**). You can open each of these projects up separately and examine the results of each parameterized simulation.

---

**Tip**

You can easily access files in your project directory directly from the **Files** view by right-clicking any cell in the corresponding row and selecting **Open Containing Folder** from the menu that opens.

---

7. Inspect the output parameter values in ANSYS Workbench.
Once all design points have been updated, you can use the table of design points to inspect the values of the output parameters you created in CFD-Post (for example, the mass flow parameters at the various outlets: floutfront, floutfoot, floutwindshield, and outlettemp). These, and the rest of the output parameters are listed to the far right in the table of design points.

**Figure 2.22: Table of Design Points (Showing Output Parameters for DP0, DP1, and DP2)**

8. Click the **Project** tab, just above the ANSYS Workbench toolbar to return to the **Project Schematic**.

9. View the list of files generated by ANSYS Workbench (optional).

   **View → Files**

   The additional files for the new design points are stored with their respective project files since you exported them.

10. Save the project in the current state in ANSYS Workbench.

   In the main menu, select **File → Save**.

11. Quit ANSYS Workbench.

   In the main menu, select **File → Exit**.

### 2.4.8. Postprocessing the New Design Points in CFD-Post

In this section, you will open the ANSYS Workbench project for each of the design points and inspect the vector plots based on the new results of the simulations.

1. Study the results of the first design point (DP1).

   a. Open the ANSYS Workbench project for the first design point (DP1).

      In your current working folder, double-click the `fluent-workbench-param_dp1.wbpj` file to open ANSYS Workbench.

   b. Open CFD-Post by double-clicking the **Results** cell in the Project Schematic for the Fluid Flow (Fluent) analysis system.

   c. View the vector plot colored by temperature. Ensure that **Range** in the **Color** tab is set to **User Specified** and the **Min** and **Max** temperature values are set to 273 K and 310 K, respectively.
d. View the vector plot colored by pressure. Ensure that **Range** in the **Color** tab is set to **Global**.
e. View the vector plot colored by velocity. Ensure that Range in the Color tab is set to Global.
f. When you are finished viewing results of the design point DP1 in ANSYS CFD-Post, select **File → Close CFD-Post** to quit ANSYS CFD-Post and return to the ANSYS Workbench **Project Schematic**, and then select **File → Exit** to exit from ANSYS Workbench.

2. Study the results of the second design point (DP2).
   
   a. Open the ANSYS Workbench project for the second design point (DP2).

   In your current working folder, double-click the `fluent-workbench-param_dp2.wbpj` file to open ANSYS Workbench.

   b. Open CFD-Post by double-clicking the **Results** cell in the Project Schematic for the Fluid Flow (Fluent) analysis system.
c. View the vector plot colored by temperature. Ensure that Range in the Color tab is set to User Specified and the Min and Max temperature values are set and the Min and Max temperature values are set to 273 K and 310 K, respectively.

Figure 2.26: Vectors Colored by Temperature (DP2)

d. View the vector plot colored by pressure. Ensure that Range in the Color tab is set to Global.
e. View the vector plot colored by velocity. Ensure that **Range** in the **Color** tab is set to **Global**.
3. When you are finished viewing results in ANSYS CFD-Post, select File → Close CFD-Post to quit ANSYS CFD-Post and return to the ANSYS Workbench Project Schematic, and then select File → Exit to exit from ANSYS Workbench.

2.4.9. Summary

In this tutorial, input and output parameters were created within ANSYS Workbench, ANSYS Fluent, and ANSYS CFD-Post in order to study the airflow in an automotive HVAC system. ANSYS Fluent was used to calculate the fluid flow throughout the geometry using the computational mesh, and ANSYS CFD-Post was used to analyze the results. ANSYS Workbench was used to create additional design points based on the original settings, and the corresponding simulations were run to create separate projects where parameterized analysis could be performed to study the effects of variable angles of the inlet valves, velocities, and temperatures. Also, note that simplified solution settings were used in this tutorial to speed up the solution time. For more improved solution accuracy, you would typically use denser mesh and higher order discretization for all flow equations.